What is your SwiftKey bug?

Vibration not working properly on Sony Xperia Z2

3 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Zhenyu Tan shared this idea  ·   ·  Admin →

    8 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • John Paul Strange commented  · 

        It is a factory defect. I tried six different Z2's and out of those six, two of those worked perfect with the haptic feedback. The others were too weak, even on the highest setting. My advice is to return for an exchange or return under warranty.

      • Anna commented  · 

        happening to my new z2 too. after factory reset, still no vibration. anyone know how to fix?

      • Anonymous commented  · 

        Funny how this is the top result when I searched z2 vibration. It's the exact same problem I have. No such problems on other phones. At 25 it feels like my phone is slightly squeaking under the weight of my fingers, hardly vibrating.

      • David Le commented  · 

        Happening to me too on my z2! Have to set it above 30ms to feel anything.

      • Anonymous commented  · 

        What is going on with the z2 vibration

      • Frank commented  · 

        Omg me either. SO what do we call this? Factory defect?

      • Michi commented  · 

        I have the same Problem.

      • Zhenyu Tan commented  · 

        As stated above, vibration is not working at anything below 30ms. Even at 30ms vibration is still weak, anything above that would result it it not working properly as well when I type fast.

        Currently running on Android 4.4.2, SwiftKey version 4.4.6.275

      Feedback and Knowledge Base