What is your SwiftKey bug?

Language pack download error

I have been using swiftkey for several years and really love the app. Im using a freshly wiped galaxy s4 gt_i9500 rooted, twrp recovery rom and a rooted vanilla install of vanilla 4.4.2 rom.

I have recently done a factory reset. I was concerned swiftkey was causing battery drain and reboot loops but i have no evidence thereof.

My current problem is that i am not able to install / download language packs. I have read many reports of this and have tried fixes suggested.

I have tried deleting app data using settings manage apps. I have uninstalled the app. I have rebooted into recovery and wiped dalvik and regular cache. And then reinstalled

I have also lookes for the files that were described in other solutions. I actually deleted the scdcard /android folder.

Currently I do no know how to proceed. Please assist

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Dr. A. Z. Baldinger shared this idea  ·   ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  · 

        Yes, I have found a solution. This applies if you have KitKat and are running a custom ROM with Root. Download "FolderMount" from the Google App store. Run the program and it will show that there is a problem with the permissions on your folders and it will fix it. Run the fix, reboot and re-do the process of installing swiftkey and you will see that the language pack will have downloaded successfully. Originally found here: http://forum.xda-developers.com/showpost.php?p=54064299&postcount=1478

      • Hans Immel commented  · 

        on my Samssung Tab Pro 10.1 T-520 (rooted) its longer possible to
        update or download a language pack. "Languagepack cannot be saved
        in memory"

        It also complains about "no connection to internet" though there
        ist a live wifi-connection, as anything else works.

        Deleted Data, deinstalled and reinstaleld app. Didnt help.

      • Oscar commented  · 

        I have this problem too, with same language packs (including all the spanish that is what I want) I got the error "error al descartar. Paquete de idioma no valido". Other languages works well.

        The error appeared with last language pack update. I try to apply the update and I get the error, I uninstalled and reinstalled, deleting the android/data folder, the app data and nothing works.

      • Nacho commented  · 

        I have the same problem. Has anyone found a solution?

      Feedback and Knowledge Base